Имя: Пароль:
1C
 
УПП - Больничные - ФСС (Ошибка импорта схемы) ☑
0 serg999
 
11.01.22
✎
15:22
Добрый день. При заполнении больничного выдает ошибку (УПП: 1.3.173.1)
Временные проблемы в ФСС или кардинально поменяли принцип работы с больничными?

{(1)}: Ошибка при вызове конструктора (WSОпределения)
WSОпределения = Новый WSОпределения(ФайлОписанияВебСервиса,,, ИнтернетПрокси,, СоединениеSSL)
по причине:
Ошибка импорта схемы
по причине:
Ошибка доступа к файлу 'https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/sedo/Sedo.xsd'
по причине:
Ошибка работы с Интернет:  Не могу установить соединение
1 RomaH
 
naïve
11.01.22
✎
15:24
это нормально
'https://eln.fss.ru/ws-insurer-crypto-v20/ периодически висит
2 RomaH
 
naïve
11.01.22
✎
15:25
<soap:Envelope>
<soap:Body>
<soap:Fault>
<faultcode>soap:Server</faultcode>
<faultstring>Could not find xsd ../../xsd/v01/sedo/Sedo.xsd'</faultstring>
</soap:Fault>
</soap:Body>
</soap:Envelope>
3 RomaH
 
naïve
11.01.22
✎
15:29
но вроде все доступно - что то я там Sedo не нахожу внутри
4 serg999
 
11.01.22
✎
15:36
Похоже проблема на стороне ФСС ... из 10 попыток, может 1 раз заполнить.
Интересно, что ошибки разные  выдает ..
5 RomaH
 
naïve
12.01.22
✎
07:15
(4) по этому поводу рекомендую схемы у себя локально положить - что бы меньше не нужных обращений в ФСС было

<?xml version='1.0' encoding='UTF-8'?>
<wsdl:definitions xmlns:xs="http://www.w3.org/2001/XMLSchema"
                    xmlns:wsdl="http://schemas.xmlsoap.org/wsdl/"
                    xmlns:soap="http://schemas.xmlsoap.org/wsdl/soap/"
                    xmlns:ins="http://www.fss.ru/integration/types/eln/ins/v01"
                    xmlns:fs="http://www.fss.ru/integration/ws/fault/v01"
                    xmlns="http://www.fss.ru/integration/ws/eln/ins/v01"
                    name="FileOperationsLnService"
                    targetNamespace="http://www.fss.ru/integration/ws/eln/ins/v01">
    <wsdl:import location="http://dkb/LnService/Faults.wsdl"
                   namespace="http://www.fss.ru/integration/ws/fault/v01">
    </wsdl:import>


все импорты заменить
6 NorthWind
 
12.01.22
✎
07:17
(5) а если обновятся? ФСС об этом не всегда докладает когда что-то у себя делает :)
7 RomaH
 
naïve
12.01.22
✎
07:21
(6) если обновятся - то вывалится ошибка валидации - либо вы прочитать не сможете сообщение от ФСС, либо ФСС от вас
8 serg999
 
12.01.22
✎
10:52
Вечером проверял более менее работает, а днем вообще никак .. расчетчики воют :(
(5) Не могу понять, как схемы можно локально выложить, они же в запросе указаны ?
9 RomaH
 
naïve
12.01.22
✎
11:24
(8) к схемам идет обращение через "точку входа" - это общий макет в кофиге - поищи в макетах "FileOperationsLnService"

1С первую и вторую схему вроде как адаптировали под локальное использование - то что в общем макете, но вот остальные оставили снаружи

можно извратиться и засунуть все наружные в этот же макет, но проще скачать все внешние схемы, опубликовать их внутри и поправить внутри их импорты на свои пути

https://ibb.co/6YYLTYg
10 NorthWind
 
12.01.22
✎
22:34
ох, бида-бида. Поанализировал фиддлером запросы на получение данных больничного по номеру и увидел, что 1С дергает WSDL и XSD в количестве 11 штук аж 4 раза подряд одни и те же. Это ж в несколько раз увеличивает вероятность сбоя. И если так делает весь 1Совский софт по всей России... так ведь что угодно положить можно.
11 RomaH
 
naïve
13.01.22
✎
07:23
ну как бы ... это "решение" от ФСС - они так описание сервиса сделали - нет что бы все в одном
12 NorthWind
 
13.01.22
✎
07:30
(11) не, тут дело не в ФСС. Вот мы по номеру выкачиваем больничный в УПП. Там дергается 9 штук XSD-схем и 2 WSDL-я.
Я бы понял если бы это произошло один раз. Но это делается четыре раза с одними и теми же схемами - вместо того чтобы один раз все вытащить, построить интерфейс и дальше просто обращаться к соответствующей точке (или точкам) входа. Понятно, что любое кэширование схем очень сильно поможет от косяков в таком случае.
И сбои происходят каждый раз в разных местах. Если бы вытаскивалось это все один раз - работа бы шла в четыре раза стабильнее.
13 RomaH
 
naïve
13.01.22
✎
08:02
ну как бы - создать запрос
потом прочитать то, что получили

и вся "схема" получается одной строчкой
Определения = Новый WSОпределения(ИмяФайлаWSDL,...
14 NorthWind
 
13.01.22
✎
09:31
(13) Три файлика с самыми длинными именами вы по каким ссылкам качали? Фиддлер мне их не показал...
Остальные схемки получилось вытянуть.
15 NorthWind
 
13.01.22
✎
09:53
раскопал. Осталась только *LnMo.xsd
16 RomaH
 
naïve
13.01.22
✎
12:29
(15) не понял - не такого - у нас и МО и работодатель - весь список файлов на картинке выше
17 RomaH
 
naïve
13.01.22
✎
12:29
+(16) вижу - по серединке
18 RomaH
 
naïve
13.01.22
✎
12:30
(14) у нас мед организация - нам надо больше
19 NorthWind
 
13.01.22
✎
12:39
(18) и я так понимаю, в схемках после выкачки вы правили секции import, чтобы рекурсивно тоже качалось с локального сервера...

Я соорудил вот такой батник

wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl --output-document c:\inetpub\wwwroot\LnService\FileOperationsLnService.wsdl
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/eln/FileOperationsLnIns.xsd --output-document c:\inetpub\wwwroot\LnService\FileOperationsLnIns.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl=../Faults.wsdl --output-document c:\inetpub\wwwroot\LnService\Faults.wsdl
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/Fault.xsd --output-document c:\inetpub\wwwroot\LnService\Fault.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/dic/FaultCode.xsd --output-document c:\inetpub\wwwroot\LnService\FaultCode.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/sedo/Sedo.xsd --output-document c:\inetpub\wwwroot\LnService\Sedo.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/Organization.xsd --output-document c:\inetpub\wwwroot\LnService\Organization.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/Common.xsd --output-document c:\inetpub\wwwroot\LnService\Common.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/Errors.xsd --output-document c:\inetpub\wwwroot\LnService\Errors.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/Person.xsd --output-document c:\inetpub\wwwroot\LnService\Person.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/IdentityDocument.xsd --output-document c:\inetpub\wwwroot\LnService\IdentityDocument.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/Eln.xsd --output-document c:\inetpub\wwwroot\LnService\Eln.xsd
wget --no-check-certificate https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/eln/WsSecurity.xsd --output-document c:\inetpub\wwwroot\LnService\WsSecurity.xsd

nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/" -t:"" c:\inetpub\wwwroot\LnService\*.xsd
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/" -t:"" c:\inetpub\wwwroot\LnService\*.wsdl

nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/eln/" -t:"" c:\inetpub\wwwroot\LnService\*.xsd
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/eln/" -t:"" c:\inetpub\wwwroot\LnService\*.wsdl

nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/dic/" -t:"" c:\inetpub\wwwroot\LnService\*.xsd
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/dic/" -t:"" c:\inetpub\wwwroot\LnService\*.wsdl

nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/sedo/" -t:"" c:\inetpub\wwwroot\LnService\*.xsd
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/sedo/" -t:"" c:\inetpub\wwwroot\LnService\*.wsdl

nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl=../Faults.wsdl" -t:"Faults.wsdl" c:\inetpub\wwwroot\LnService\*.xsd
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl=../Faults.wsdl" -t:"Faults.wsdl" c:\inetpub\wwwroot\LnService\*.wsdl

и все получилось очень даже неплохо. wget и nhrt надо поставить, понятное дело.
20 Kigo_Kigo
 
13.01.22
✎
14:45
(19) А что надо сделать что бы он заработал?
21 NorthWind
 
13.01.22
✎
15:11
(20) нужен веб-сервер. Я использовал IIS от Windows 2008 R2. Можно и апач, это кому как удобнее.

Для публикации документов у IIS по умолчанию используется папка c:\inetpub\wwwroot. Там создается папка LnService. Этот батник с помошью утилиты wget (http://gnuwin32.sourceforge.net/packages/wget.htm) выкачивает в нее все необходимые схемки. Но перед тем, как их использовать, нужно их немного подредактировать, потому что в них есть ссылки друг на друга, но при этом искать их предполагается на fss.ru.

Выглядит это примерно вот так

<xs:import namespace="http://www.fss.ru/integration/types/dic/fault/v01" schemaLocation="https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/dic/FaultCode.xsd"/>

Нам надо такие вещи поправить на локальные в текущей папке, то есть сделать

<xs:import namespace="http://www.fss.ru/integration/types/dic/fault/v01" schemaLocation="FaultCode.xsd"/>

Для этого можно использовать утилиту командной строки, которая умеет в куче текстовых файлов заменять одну строку на другую.
Я нашел вот такую https://nhutils.ru/blog/nhrt/. Ну или другую подобную, их много, может, в винде даже штатные способы есть, не знаю. Использовал эту утилиту для замен, это вторая часть батника.

А дальнейшее зависит от вашей конфигурации 1С. В УПП необходимые ссылки находятся в общем макете ОбменДаннымиФССЭЛНОписаниеВебСервиса. Его нужно снять с замка и в секциях import поменять ссылки так, чтобы они ссылались на ваш локальные схемы. У меня это выглядит примерно так

<xs:import namespace="http://www.fss.ru/integration/types/organization/v01" schemaLocation="http://srv-02/LnService/Organization.xsd"/>

И все. Дальше запускаете 1С с фиддлером, пробуете запросить данные больничного и видите, что обращение к fss.ru идет только когда система обращается к точке доступа. Все схемы стаскиваются с локального веб-сервера.
22 NorthWind
 
13.01.22
✎
15:25
Сегодня, кстати, ФСС отживел, по-моему. Более-менее вытаскивается все, и достаточно быстро.
23 Demetri__
 
17.01.22
✎
13:46
Не работает с пятницы, так же разные ошибки при запросе заполнить БЛ. Сертификат поставили новый от 15.12.2021
Конфа УПП последний релиз

У кого как?
24 NorthWind
 
17.01.22
✎
13:57
(23) норм. Сегодня проверял со своими изменениями от (19)-(21) - супер, шустренько. Серты свежие с лк.фсс.ру, второй от 17, нижний от 15.12.2021.
25 NorthWind
 
17.01.22
✎
13:59
И да, RomaH, спасибо за плодотворную идею. По-хорошему, это можно было бы оформить как публикациб на ИС.
26 RomaH
 
naïve
20.01.22
✎
07:13
к стати - вопрос к "работодателям" на ЗУП и прочих УПП
какая длина у вас на должности врачей?

тут поймали в "1С:Больничных" ограничение в конфе сначала на 100 символов потом в 150 (в разных местах)

фишка в том, что "строка" в схеме ЭЛН не ограничена - и поймали внешний больничный с должностью на 151 символ
соответственно после добавления "наших" данных в больничный, подписания и отправки ФСС ругается - что наш ЭЛН не соответствует тому что у них.

так что - это еще одна мина замедленного действия от 1С
27 NorthWind
 
20.01.22
✎
07:58
(26) Ну не сказать чтоб не ограничена - 300 символов.

    <xs:simpleType name="doctorRole">
        <xs:annotation>
            <xs:documentation>
                Должность врача
            </xs:documentation>
        </xs:annotation>
        <xs:restriction base="xs:string">
            <xs:maxLength value="300"/>
        </xs:restriction>
    </xs:simpleType>
28 RomaH
 
naïve
20.01.22
✎
07:59
(27) понятно

а в ЗУП?
29 NorthWind
 
20.01.22
✎
08:12
В ЗУП не знаю. В УПП встречается в доке НачислениеПоБольничномуЛисту, ТЧ ОсвобождениеОтРаботыВЛисткеНетрудоспособности, атр ДолжностьВрача - там 300. Затем: РеестрСведенийВФССОПособияхПоНетрудоспособности, ТЧ РаботникиОрганизации. Там аж 6 атрибутов с должностями врачей. Все по 300 символов. Речь про последнюю УПП 173.2.
30 serggld
 
28.01.22
✎
11:48
Я сделал почти как тут описано и вроде как больничные стали загружаться. Только вместо поднятия веб-сервера я расшарил сетевую папку на доступ и скачал в неё все файлы (список см. выше) в них соотвественно заменил ссылки на локальные (в notepad++), а именно например с начиная с макета: <wsdl:import location="file:////192.168.0.122/fss/Faults.wsdl"... вместо <wsdl:import location="https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl=../Faults.wsdl"...
Мне кажется с папкой проще чем с веб-сервером.
Теперь вот нужно придумывать костыли по предварительной проверке этих файлов перед загрузкой больничного на предмет изменения.
31 Kigo_Kigo
 
28.01.22
✎
11:55
(30) Не облегчайте жизнь ФСС, то бишь - делаем запрос ФСС - ошибка, тогда лезем у себе )))
Если ошибки нет, заменяем у себя все файлы новыми (а может и такими же, не сравнивать же их ей богу) полученными от фсс
32 NorthWind
 
28.01.22
✎
13:54
(30) а зачем?
33 NorthWind
 
28.01.22
✎
13:56
(31) >> делаем запрос ФСС - ошибка, тогда лезем у себе
это очень долго, даже с шустрым инетом. Я как сделал локальные схемы - офигел насколько шустро этот запрос больничных стал летать. Небо и земля. Ну его нафиг этот ФСС, чем меньше туда лазишь тем лучше
34 RomaH
 
naïve
31.01.22
✎
07:21
(30) "Теперь вот нужно придумывать костыли по предварительной проверке этих файлов перед загрузкой больничного на предмет изменения."
зачем? - насколько я понимаю это ... "правила" создания и чтения xml - если "правила" поменяются, то ...
35 La4esis
 
01.02.22
✎
10:50
Ошибка на релизе 1.3.173.3 повторяется?
36 NorthWind
 
01.02.22
✎
11:27
(35) она от релиза не зависит. Отлуп выдают серверы ФСС, скорее всего, по чрезмерному количеству запросов. А может еще по какой причине.
37 NorthWind
 
01.02.22
✎
11:45
Рабочий способ решения описан в этой ветке. Ну или ждать изменений API или улучшения ФССом своих серваков.
38 La4esis
 
02.02.22
✎
13:17
Ребят, обновление 1.3.173.3 решило проблему
39 Egor4864
 
02.02.22
✎
13:17
версия 1.3.173.3 решила данную проблему
40 NorthWind
 
02.02.22
✎
14:51
я бы на это сильно не рассчитывал, ребят. Обмен ЭДО с ФСС в 173.3 не поменялся по сравнению со 173.2, во всяком случае мой измененный модуль так и остался измененным. А серверы ФСС и раньше иногда работали стабильно (см. (22)), а иногда начинали вести себя странно. Скорее всего, сейчас опять период стабильной работы. Дай Бог, чтобы он продлился долго.
41 serggld
 
04.02.22
✎
15:59
(40) в УПП173.3 полностью переработали Макет со правилами обмена с ФСС - убрали из него импорт. И теперь он совсем не работает. При попытке загрузить схему обмена выдает ошибку "Неверный формат". Пришлось на макет из 173.2 откатывать (с модификациями конечно). Другого решения пока нет.
42 NorthWind
 
04.02.22
✎
19:09
(41) ну если они пихнули все схемы в один макет - то это наоборот хорошо. Значит, колхозинг из (19) больше не нужен
43 NorthWind
 
06.02.22
✎
16:28
Действительно, в 173.3 1С запихнула все схемы локально в один макет. Я изначально проверил только модуль ОбменСведениямиОПособияхСФСС, который не изменился, но не посмотрел в сам загружаемый макет - а зря, потому что изменился как раз он. Ну что имею сказать... это ж очень хорошо, наши мучения с ФСС в существенной мере закончились.
44 RomaH
 
naïve
07.02.22
✎
15:02
(43) а что с "неверным форматом" из (41)

ну как? сегодня смотрю вообще затык - ФСС даже честно признался. что у них внутрення ошибка сервера
45 NorthWind
 
07.02.22
✎
15:36
(44) вчера гонял - все норм было, во всяком случае, больнюковые данные по номеру получало. Да и до этого - 173.3 у меня с конца января, и если бы были косяки, то пожаловались бы. По-видимому, работало все.
46 NorthWind
 
07.02.22
✎
15:39
попробовал прямо сейчас, в 15:38 по Москве - тягает данные больничного со штатным макетом и кодом 173.3.
47 serggld
 
07.02.22
✎
15:43
(46) А у меня не тянет. Вываливается в ошибку и хоть ты тресни. Может в платформе дело? У меня 8.3.18.1433
48 serggld
 
07.02.22
✎
15:44
Вот текст ошибки:
{<Неизвестный модуль>(1)}: Ошибка при вызове конструктора (WSОпределения)
WSОпределения = Новый WSОпределения(ФайлОписанияВебСервиса,,, ИнтернетПрокси,, СоединениеSSL)
по причине:
Неверный формат.
по причине:

message.DecryptException
    part.decryptFault
Элемент не найден
  namespace: http://www.fss.ru/integration/types/fault/v01
  localName: decryptFault

message.InternalException
    part.internalFault
Элемент не найден
  namespace: http://www.fss.ru/integration/types/fault/v01
  localName: internalFault

message.DigitalSignException
    part.digitalSignFault
Элемент не найден
  namespace: http://www.fss.ru/integration/types/fault/v01
  localName: digitalSignFault

portType.FileOperationsLnService
    abstractOperation.PrParseReestrFile
        abstractOperationFault.internalException
Сообщение не найдено
  namespace: http://www.fss.ru/integration/ws/fault/v01
  localName: InternalException

portType.FileOperationsLnService
    abstractOperation.GetPrivateLNData
        abstractOperationFault.internalException
Сообщение не найдено
  namespace: http://www.fss.ru/integration/ws/fault/v01
  localName: InternalException
49 NorthWind
 
07.02.22
✎
15:45
(47) Ну да, у меня постарше. 1С:Предприятие 8.3 (8.3.16.1876)
50 NorthWind
 
07.02.22
✎
15:46
кто-нибудь еще тестил на всяких платформах? (44), у вас как?
51 RomaH
 
naïve
07.02.22
✎
15:48
(50) у нас по старой схеме пока ... мы еще и как МО работаем
52 NorthWind
 
07.02.22
✎
16:04
(48) может, у вас макет как-нибудь оказался поврежден, кодировка поменялась или еще что-то такое? Не наблюдается проблем...
53 serggld
 
09.02.22
✎
08:44
(52) Нет, меня не кодировка поменялась, у просто режим совместимости 8.3.хх включен (используюстся Расширения). Вот и "вылезло". Я, кстати, исправил шаблон, проверил загрузку больничных. Отправил шаблон в тех.поддержку 1С. Надеюсь внесут исправления в очередное обновление. К сожалению, с XML-схемами ранее работать не приходилось, поэтому гарантию дать что всё правильно поправил не могу. Проблема была в префиксах.
...
в раздел <wsdl:definitions добавлена строка
xmlns:tns="http://www.fss.ru/integration/types/eln/ins/v01"
...
Изменено
было: <wsdl:fault message="fs:InternalException" name="internalException"> </wsdl:fault>
стало: <wsdl:fault message="InternalException" name="internalException"> </wsdl:fault>
...
Префикс "flt" заменен за "tns"
  <wsdl:message name="DecryptException">
    <wsdl:part element="tns:decryptFault" name="decryptFault"> </wsdl:part>
  </wsdl:message>
  <wsdl:message name="InternalException">
    <wsdl:part element="tns:internalFault" name="internalFault"> </wsdl:part>
  </wsdl:message>
  <wsdl:message name="DigitalSignException">
    <wsdl:part element="tns:digitalSignFault" name="digitalSignFault"> </wsdl:part>
  </wsdl:message>
54 Anarki
 
16.02.22
✎
11:29
Коллеги, как у вас на 1.3.174.1 грузятся больничные?
55 Смотрящий от 1С
 
16.02.22
✎
11:48
1.3.173.3
ФСС попросили отправить "Сведения о застрахованных лицах ФСС". При заполнении лицевые счета берет не из лицевых счетов сотрудников, а из последнего документа выплаты по ФСС. Адреса берет оттуда же. При проверке не дает выгрузить без лицевого счета и банка. То есть предполагается, что все должны хоть раз поболеть или руками заново заносить лицевые счета в "Сведения"
При выгрузке напрямую из программы поругалась, что Тензор не занес денег и его сертификат не авторизован
В файл документ можно выгрузить только построчно!  Как поступать если сотров много?
При попытке отправить напрямую через Тензор он не понял, что это за файл и отказался его принимать
56 Anarki
 
16.02.22
✎
12:19
(56) По части лицевых счетов, мы себе уже дописали, что бы вставало, это мелочи жизни. А вот то что они 1с отчетность так назойливо втюхать хотят это очень печально
57 NorthWind
 
16.02.22
✎
14:24
(56) в УПП, мне кажется, ничего уже втюхать не хотят, это труп. Но в целом использование 1С отчетности после внедрения ЭЛН и ЭТК кажется разумным - потому как слишком большой ДО стал и лазить каждый раз в несколько программ утомительно.
58 Tolpinski
 
17.02.22
✎
10:30
(55)
59 Tolpinski
 
17.02.22
✎
10:40
(55) https://infostart.ru/public/1602594/
Обработкой..мопед мой :) 4 функции и пару процедур пришлось перетянуть в обработку, отключить проверку перед выгрузкой по строке.

Переделал загрузку ЭЛН в ЗУП 2.5 по указанному рецепту, работает!
Файлы скачал руками, вгетом не качались что-то
Положил в корень c:\1c_fss,
Заменил в файлах ссылки, батнику передаю C:\1c_fss\, со слэшем в конце:
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/" -t:"%1"  %1*.*
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/eln/" -t:"%1" %1*.*
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/dic/" -t:"%1"  %1*.*
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/sedo/" -t:"%1"  %1*.*
nhrt.exe -spt:"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl=../Faults.wsdl" -t:"%1Faults.wsdl"  %1*.*
В общем модуле ОбменСведениямиОПособияхСФСС поправил Функция WSПрокси_FileOperationsLnService(НастройкиWS), макет менять не стал, потом обновлять будет сложнее
После "ОписаниеВебСервиса = ПолучитьОбщийМакет("ОбменДаннымиФССЭЛНОписаниеВебСервиса").ПолучитьТекст();" добавил:
Чем = "C:\1c_fss\"; //папка на сервере RPRZ-SPIRIT
КаталогНаДиске = Новый Файл(Чем);
Если КаталогНаДиске.Существует() Тогда
ОписаниеВебСервиса = СтрЗаменить(ОписаниеВебСервиса,"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?wsdl=../",Чем);
ОписаниеВебСервиса = СтрЗаменить(ОписаниеВебСервиса,"https://eln.fss.ru/ws-insurer-crypto-v20/FileOperationsLnService?xsd=../../xsd/v01/type/",Чем);
Иначе
ПоказатьОповещениеПользователя("Локальный каталог "+Чем+" не обнаружен, файлы описания вебсервиса будем получать с серверов фсс");
КонецЕсли;

Каталог должен лежать локально, даже на серверной базе!
Тут выложил готовые файлы
https://disk.yandex.ru/d/PTGMAjed-fA6LQ
60 Стрелец
 
21.02.22
✎
12:38
(59) - Спасибо, всё получилось!
Ошибка? Это не ошибка, это системная функция.