Имя: Пароль:
1C
1С v8
Выгрузка загрузка данных xml, нарушение прав доступа ☑
0 Soul771
 
06.01.18
✎
22:28
Добрый вечер.
Хочу перетащить справочники, константы, записи регистров сведений и прочее в чистую базу. Использую обработку "Выгрузка и загрузка данных XML" для 83, с ИТС. Выгружаю все, кроме документов и рег.накопления. При загрузке в чистую базу под админом с полными правами выдает ошибку:"Нарушение прав доступа". Запускала в режиме упрвляемого приложения, в режиме управляемого и обычного, толстый клиент, тонкий клиент - без результата. Погуглила,проблема возникала у многих, но как исправили- информации нет.. Подскажите, сталкивался ли кто с пободным казусом?...
1 Soul771
 
06.01.18
✎
22:36
8.3.10.2561, розница базовая 2.2.5.22 (но ошибки возникли и на других конфигурациях, по отзывам). На компе также все права,в 1С протыкала все-все галки в правах (на случай, вдруг в полные права что-то нежданно перестало вмещаться)..
Отладчик выдал; {ВнешняяОбработка.ВыгрузкаЗагрузкаДанныхXML.МодульОбъекта(227)}: Ошибка при вызове метода контекста (Записать)
            ЗаписанноеЗначение.Записать();
по причине:
Нарушение прав доступа!

вот кусок кода, на котором спотыкается:
Пока Сериализатор.ВозможностьЧтенияXML(ЧтениеXML) Цикл
        
        Попытка
            ЗаписанноеЗначение = Сериализатор.ПрочитатьXML(ЧтениеXML);
        Исключение
            ВосстановитьИспользованиеИтогов();
            ВызватьИсключение;
        КонецПопытки;
        
        Если ПриЗагрузкеИспользоватьРежимОбменаДанными Тогда
            
            Попытка // Планы обмена свойства ОбменДанными не имеют
                ЗаписанноеЗначение.ОбменДанными.Загрузка = Истина;
            Исключение
            КонецПопытки;
            
        КонецЕсли;
        
        Попытка
            ЗаписанноеЗначение.Записать();
        Исключение
2 Aleksey
 
06.01.18
✎
22:36
не все данные доступны всем пользователем, в том числе админом.
Зачастую какой нибудь специфичный справочник не имеет доступа к изменению пользователей
3 Aleksey
 
06.01.18
✎
22:37
зайди в ЖР и посмотри на что ругается
4 Neg
 
06.01.18
✎
22:38
"интерактивное открытие внешних отчетов и обработок" галка стоит?
5 Aleksey
 
06.01.18
✎
22:38
(4) этот тут не причем
6 Neg
 
06.01.18
✎
22:38
(5) а вдруг?
7 Soul771
 
06.01.18
✎
22:41
(2),(3) -спасибо. Вот что в журнале регистрации : "{ОбщийМодуль.ОбщегоНазначения.Модуль(2084)}: Регламентное задание недоступно по функциональным опциям
или не поддерживает работу в текущем режиме работы программы.
Выполнение прервано." Регл.заданание :Обновление индекса ПДД.
При чем тут оно,задание это,не пойму......
(4)-да, и эта, и все-все-все галки стоят...
8 Aleksey
 
06.01.18
✎
22:42
(7) нет там именно должна быть ошибка доступа, и ссылка на объект методанных на которую он не может получить доступ
9 Aleksey
 
06.01.18
✎
22:43
Ну у тебя всегда есть возможность пойти по длинному пути. Выгрузить модуль во внешний файл и скормить его обработчику загрузки и тогда уже в отладчики ловить блох
10 Soul771
 
06.01.18
✎
22:53
(8) - благодарю! прогрузила еще раз, уже в режиме предприятия зашла в журнал регистрации, последняя строка :"Доступ. Отказ в доступе.Константа. Ключ области данных.Отказ права: изменение". Не как ошибка, а просто как событие отобразилось.
Сейчас посмотрю, что это за константа, нафига она.....
11 Aleksey
 
06.01.18
✎
23:00
ну вот служебная константа, которая ручками менять незя. Просто убери её из выгрузки
12 Soul771
 
06.01.18
✎
23:23
(11) - ага. Поиск по рук-вам разработчика и пользователя 2012 г совпадений не нашел, быстрый запрос к гуглу тоже. Предполагаю, что-то связанное с идентификацией данных, возможно, при обновлении или обмене... Обменов у клиента нет, ручками в эту константу не залезть, выгрузила без нее, когда-нибудь мож узнаем, зачем сие придумано)
Благодарю за помощь!
При загрузке уже новые веселые ошибки, теперь споткнулись на Константе ПровайдерSms, сейчас попробую исправить по тому же принципу)
13 Aleksey
 
06.01.18
✎
23:44
(12) по идеи это кусок от фреша (база в облаках).
14 Soul771
 
07.01.18
✎
00:09
(13) - спасибо)
выгрузила без этих двух констант, при загрузке все равно ругнулся на ПровайдерSMS, предложил запустить с параметром "/С ЗапуститьОбновлениеИнформационнойБазы", запустила, вроде все нормально загрузилось (проверила номенклатуру, контрагентов, цены)Еще ругался на то, что в "Do not copy" не совпал параметр(после обновления вылезло окошко, тыкнула, что база перемещена, все ок)
Спасибо вам! С Рождеством! Добра, здоровья, любви!
Компьютер — устройство, разработанное для ускорения и автоматизации человеческих ошибок.