Имя: Пароль:
1C
1С v8
Не открывается ОСВ по счёту ☑
0 Infinite88
 
25.11.23
✎
10:44
Всем привет!

При открытии ОСВ по счёту выходит ошибка.
Исходные данные:
-1С:Предприятие 8.3 (8.3.23.1912)
-Бухгалтерия предприятия (базовая), редакция 3.0 (3.0.131.34)
-сервер 1с на ОС Ubuntu 22.04
-БД PostgreSQL 15

Можно как то исправить?

Текст ошибки:
Ошибка при вызове метода контекста (Получить)
{ОбщийМодуль.БухгалтерскиеОтчетыВызовСервера.Модуль(2417)}:ДополнительныеСвойства = Настройки.ДополнительныеСвойства.ДанныеОтчета.Получить();
{Отчет.ОборотноСальдоваяВедомостьПоСчету.Форма.ФормаОтчета.Форма(98)}:БухгалтерскиеОтчетыВызовСервера.ПриЗагрузкеПользовательскихНастроекНаСервере(ЭтаФорма, Настройки);
{ОбщаяКоманда.ОборотноСальдоваяВедомостьПоСчету.МодульКоманды(6)}:ОткрытьФорму("Отчет.ОборотноСальдоваяВедомостьПоСчету.Форма", ПараметрыФормы, ПараметрыВыполненияКоманды.Источник, Истина, ПараметрыВыполненияКоманды.Окно, ПараметрыВыполненияКоманды.НавигационнаяСсылка);

по причине:
Ошибка формата потока
1 Волшебник
 
25.11.23
✎
11:24
Тут не исправить, тут спасать надо.
База может разрушиться, а может уже разрушена.

Выключайте пользователей, вызывайте программистов и админов

Свистать всех наверх!
2 Гена
 
гуру
25.11.23
✎
11:29
(0) А по какому конкретно счёту смотрите?
3 Гена
 
гуру
25.11.23
✎
11:47
(1) Испугали человека )
Просто Телепат 2.0 предположил, что ОСВ смотрят по 60 или 62, или 76
4 Волшебник
 
25.11.23
✎
12:20
(3) Ошибка формата потока может означать всё, что угодно.
У нас был случай, когда один программист поставил себе другой релиз платформы, выложил в хранилище справочник. Справочник перестал открываться вот с такой ошибкой. Попробуйте вычислить по тексту этой ошибки причину. Это невозможно.
5 Гена
 
гуру
25.11.23
✎
12:34
(4) Хайли лайкли тут не прямая ОФП, ведь тогда бы выскочило стандартное окошко без всякой расшифровки.
Обратите внимание на древность релиза. Если автор преодолеет испуг и подтвердит 60,62,76 - то это на 99% ошибка:
https://bugboard.v8.1c.ru/error/000142474
6 Гена
 
гуру
25.11.23
✎
12:38
Ну и 1% остаётся на то, что пользователь прорвал защиту и сохранил несовместимую свою настройку в дополнительных. Тогда просто снести все настройки обновлением стандартной.
7 Гость из Мариуполя
 
25.11.23
✎
14:36
Бухгалтерия базовая? сервер 1С? БД PostgreSQL 15?
А что, так можно было, что-ли?
А смысл? базовую на сервер? Все рано ведь пользователь только в одном лице..

Ну а по сути для начала тупо почистить кэши. И серверный и пользовательский.
8 Волшебник
 
25.11.23
✎
15:30
(7) Кстати, да. В любой непонятной ситуации первым делом надо почистить кэш. Или просто базу перепрописать в список.
9 Infinite88
 
25.11.23
✎
17:22
Я думаю, теперь напишу более подробно))
Ко мне обратились с просьбой помочь. Со слов заявителя - база тупо не открывается. При беглом взгляде на удалённом компе сделал выводы:
- 1С клиент на ноуте
- База в файловом режиме на диске, на этом же ноуте
- смог зайти в конфигуратор и выгрузить dt.
- ругался, что так нельзя) (бэкапов нет тоже)

После всего этого:
- загрузил dt к себе на сервер.
- при тесте было обнаружено 2 неуникальных индекса (исправлено)
- база стала работать, но осталась только эта ошибка
- пытался делать всё, что нашёл с подобно ошибкой
10 Гость из Мариуполя
 
25.11.23
✎
22:26
(9) заведи нового пользователя, попробуй под ним.
Этим ты отсечешь возможно некорректные настройки текущего пользователя.
Может и правда,как сказал Гена, дело в настройках...
11 Infinite88
 
25.11.23
✎
23:19
Завёл нового пользователя - тоже самое.
Возможно действительно база слегка пожухла...
12 Волшебник
 
26.11.23
✎
01:12
(11) А я говорил... Тут всяко может быть. От простой ерунды до полной катастрофы. Но вроде в данном случае обойдётся ерундой.
13 rphosts
 
26.11.23
✎
05:59
(11) если размер позволяет - выгрузи в файловую и попробуй починить... для файловой инструменты хоть какие-то есть
14 rphosts
 
26.11.23
✎
06:00
+ (13) кроме того есть ещё вариант написать в техподдержку, говорят там помогают но нужно будет ждать
15 Волшебник
 
26.11.23
✎
08:53
(9) Неуникальные индексы можно аккуратно снести и выгрузить в dt, потом развернуть в файловой.

Индексы должны быть пересозданы по исходным данным при загрузке базы.
16 Alexor
 
26.11.23
✎
09:48
(0) я бы попробовал релиз платформы понизить,конфа старая что там требовалось смотри.

Или наоборот обновить конфу.
Платформу лучше 22 последнюю поставить.

Не поможет. Универсальная загрузка выгрузка через xml перенести данные.
17 shuhard
 
26.11.23
✎
10:10
(11)[Возможно действительно база слегка пожухла]
дык проверь, что у документов хотя бы движухи читаются
18 Infinite88
 
27.11.23
✎
20:41
Документы живые. Остальные отчёты формируются.
Пытался разными способами что-то исправить - безуспешно.
Есть копия от конца октября. Там всё живое, но неактуальное)
19 Infinite88
 
28.11.23
✎
09:53
Смог победить проблему. Загрузил базу в MSSQL. Просмотрел через ProFiler, что запрос шёл в таблицу _SystemSettings. Я так понял там и хранились настройки, которые 1С не могла считать (бесовское ПО :)). Вычистил все данные из неё - заработало!
Всем спасибо!